CVE-2026-93657: hickory-resolver · Improper Verification of Cryptographic Signature
Affects hickory-resolverSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 0.26.2 soon.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.26.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 18 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade hickory-resolver to 0.26.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| hickory-dnshickory-resolver | Affected
| Fixed in
|
crates.iohickory-resolverpkg:cargo/hickory-resolverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade hickory-resolver to version 0.26.2 or later, where this issue is fixed. No other mitigation is indicated by the vendor advisory. Patch status is confirmed by the presence of fixed version 0.26.2.
Description
hickory-resolver versions before 0.26.2 have a vulnerability where bogus DNSSEC proof states are not properly propagated through key resolver APIs. This flaw allows attackers controlling the DNS answering zone or positioned on the network path to have forged DNS records accepted as valid, bypassing DNSSEC authentication checks. The vulnerability has a high severity score of 8.7 and affects versions prior to 0.26.2.
References
- github.com/hickory-dns/hickory-dns/security/advisories/GHSA-5j98-2g5x-46v6 (opens in a new tab)
- github.com/hickory-dns/hickory-dns/commit/30720f4fb22e5556ecbf26d2c8274ea4a9fdd238 (opens in a new tab)
- github.com/hickory-dns/hickory-dns/pull/3871 (opens in a new tab)
- github.com/hickory-dns/hickory-dns/releases/tag/v0.26.2 (opens in a new tab)
- github.com/hickory-dns/hickory-dns (opens in a new tab)
- vulncheck.com/advisories/hickory-resolver-before-0.26.2-dnssec-validation-bypass (opens in a new tab)