Skip to main content
VulnerabilityPublished Updated

CVE-2026-93956: olivier-ls PHP-FTS · Cross-site Scripting

Affects olivier-ls PHP-FTSSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.1 Medium · fixed in 1.1.3 : patch olivier-ls PHP-FTS as a priority.

Data as of 3 Nov 2026, 22:58 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.1.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
olivier-lsPHP-FTSAffected
  • =1.1.0
  • =1.1.1
  • =1.1.2
Fixed in–
GitHubolivier-ls/php-ftspkg:github/olivier-ls/php-ftsOther threatsAffected
  • =1.1.0
  • =1.1.1
  • =1.1.2
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:olivier-ls:php-fts:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected installations of olivier-ls PHP-FTS to version 1.1.3 or later, which contains the official fix for this vulnerability. No additional mitigations are indicated by the vendor advisory.

Description

A flaw has been found in olivier-ls PHP-FTS up to 1.1.2. Affected by this issue is the function SearchEngine::buildHighlights of the file src/SearchEngine.php of the component Search Engine. Executing a manipulation of the argument Query can lead to cross site scripting. The attack may be launched remotely. The exploit has been published and may be used. Upgrading to version 1.1.3 can resolve this issue. This patch is called 0b2fae333d6b022da7ed4c43e2d41aa03f91dff3. The affected component should be upgraded. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

References

Community reviews

Loading reviews…