Skip to main content
VulnerabilityPublished Updated

CVE-2026-93957: olivier-ls PHP-FTS · Incorrect Comparison

Affects olivier-ls PHP-FTSSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.3 Medium · fixed in 1.1.4 : patch olivier-ls PHP-FTS as a priority.

Data as of 3 Nov 2026, 10:58 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.1.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
olivier-lsPHP-FTSAffected
  • 1.1.0 – 1.1.3
4 affected builds
Fixed in–
GitHubolivier-ls/php-ftspkg:github/olivier-ls/php-ftsOther threatsAffected
  • 1.1.0 – 1.1.3
4 affected builds
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:olivier-ls:php-fts:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade olivier-ls PHP-FTS to version 1.1.4, which contains the official fix for this vulnerability. The vendor has released this fixed version promptly after disclosure. No other mitigation actions are indicated.

Description

A vulnerability has been found in olivier-ls PHP-FTS up to 1.1.3. This affects the function SearchEngine::matchesSingleFilter of the file src/SearchEngine.php of the component Filter Matching. The manipulation leads to incorrect comparison. Remote exploitation of the attack is possible. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.4 is able to mitigate this issue. The identifier of the patch is 0b2fae333d6b022da7ed4c43e2d41aa03f91dff3. It is suggested to upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

References

Community reviews

Loading reviews…