Skip to main content
VulnerabilityPublished Updated

CVE-2026-93962: Kamailio · Heap-based Buffer Overflow

Affects KamailioSource CVE Database V5

0
Compare

Public exploit available · CVSS 6.9 Medium.

Data as of 3 Nov 2026, 22:58 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
KamailioAffected
  • 5.8.0 – 6.2.0-dev1
23 affected builds
Fixed in–
GitHubkamailio/kamailiopkg:github/kamailio/kamailioOther threatsAffected
  • 5.8.0 – 6.2.0-dev1
23 affected builds
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:kamailio:kamailio:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Kamailio to version 6.0.8 or later to remediate this vulnerability. This official fix addresses the heap-based buffer overflow in the CDP Diameter Receiver module. No additional mitigation steps are required once the upgrade is applied.

Description

CVE-2026-93962 is a heap-based buffer overflow vulnerability in Kamailio affecting versions 5.8.0 through 5.8.8, 6.0.0 through 6.0.7, 6.1.0 through 6.1.4, and 6.2.0-dev1. The flaw exists in the shm_malloc function within the CDP Diameter Receiver module. This vulnerability can be exploited remotely without authentication. A public exploit is available. Upgrading to Kamailio version 6.0.8 or later resolves the issue.

References

Community reviews

Loading reviews…