Skip to main content
VulnerabilityPublished Updated

CVE-2026-94113: Frappe ERPNext · Missing Authorization

Affects Frappe ERPNextSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 16.34.0 or 15.121.0 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.34.0, 15.121.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Frappe ERPNext to 16.34.0 or 15.121.0.

Affected software

ProductAffectedFixed in
FrappeERPNextAffected
  • >=16.0.0 <16.34.0
Fixed in
  • 16.34.0
FrappeERPNextAffected
  • <15.121.0
Fixed in
  • 15.121.0
GitHubERPNextpkg:github/ERPNextOther threatsAffected
  • <15.121.0
  • >=16.0.0 <16.34.0
Fixed in
  • 15.121.0
  • 16.34.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict access to affected endpoints to trusted users only and monitor for suspicious authenticated access patterns related to timesheet data retrieval.

Description

CVE-2026-94113 is an information disclosure vulnerability in Frappe ERPNext affecting versions before 15.121.0 and 16.x before 16.34.0. The flaw exists in whitelisted timesheet endpoints that do not enforce doctype permissions, allowing authenticated attackers to access sensitive billable time log data without proper authorization.

References

Community reviews

Loading reviews…