Skip to main content
VulnerabilityPublished

CVE-2026-9502: GNU LibreDWG · Heap-based Buffer Overflow

Affects GNU LibreDWGSource CVE Database V5

0

Public exploit available · CVSS 4.8 Medium.

Data as of 27 Oct 2026, 17:11 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
GNULibreDWGAffected
  • 0.1 – 0.14
14 affected builds
Fixed in–
GitHublibredwg/libredwgpkg:github/libredwg/libredwgOther threatsAffected
  • 0.1 – 0.14
14 affected builds
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:gnu:libredwg:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch identified by commit e501cb9926c1e9a07a0d1cc997f3e69e9be801c9 is recommended to fix this vulnerability. Since no official vendor advisory or remediation level is provided, users should apply this patch or upgrade to a version beyond 0.14 if available.

Description

A vulnerability was identified in GNU LibreDWG up to 0.14. This affects the function decompress_R2004_section of the file src/decode.c of the component Dwgread Utility. The manipulation leads to heap-based buffer overflow. The attack must be carried out locally. The exploit is publicly available and might be used. The identifier of the patch is e501cb9926c1e9a07a0d1cc997f3e69e9be801c9. To fix this issue, it is recommended to deploy a patch.

References

Community reviews

Loading reviews…