CVE-2026-9530: GNU LibreDWG · Out-of-bounds Read
Affects GNU LibreDWGSource CVE Database V5
Public exploit available · CVSS 4.8 Medium.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GNULibreDWG | Affected
| Fixed in– |
GitHublibredwg/libredwgpkg:github/libredwg/libredwgOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:gnu:libredwg:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch commit (8f03865f37f5d4ffd616fef802acc980be54d300) has been referenced to address this vulnerability. However, official patch availability or vendor advisory confirmation is not provided. It is advisable to apply the patch or upgrade to a version beyond 0.14 once an official fix is released. Until then, restrict local access to trusted users only.
Description
A weakness has been identified in GNU LibreDWG up to 0.14. The impacted element is the function read_2004_compressed_section of the file src/decode.c of the component Dwgbmp Utility. Executing a manipulation can lead to out-of-bounds read. The attack requires local access. The exploit has been made available to the public and could be used for attacks. This patch is called 8f03865f37f5d4ffd616fef802acc980be54d300. It is advisable to implement a patch to correct this issue.
References
- vuldb.com/vuln/365549 (opens in a new tab)
- vuldb.com/vuln/365549/cti (opens in a new tab)
- vuldb.com/submit/814275 (opens in a new tab)
- github.com/LibreDWG/libredwg/issues/1248 (opens in a new tab)
- github.com/HackC0der/CVE-Repos/blob/main/libredwg/libredwg_6d6a339_heap_oob_write_read_2004_compressed_section.dwg (opens in a new tab)
- github.com/LibreDWG/libredwg/commit/8f03865f37f5d4ffd616fef802acc980be54d300 (opens in a new tab)
- gnu.org (opens in a new tab)