Skip to main content
VulnerabilityPublished

CVE-2026-95624: tauri-plugin-updater · Improper Access Control

Affects tauri-plugin-updaterSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.8 Medium : upgrade to 2.12.0 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.12.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade tauri-plugin-updater to 2.12.0.

Affected software

ProductAffectedFixed in
Tauritauri-plugin-updaterAffected
  • >=2.8.0 <2.12.0
Fixed in
  • 2.12.0
crates.iotauri-plugin-updaterpkg:cargo/tauri-plugin-updaterOther threatsAffected
  • >=2.8.0 <2.12.0
Fixed in
  • 2.12.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid exposing the 'check' IPC command with allowDowngrades parameter to untrusted frontend code. Mitigate frontend XSS vulnerabilities to prevent exploitation of this issue.

Description

CVE-2026-95624 is an improper access control vulnerability in the Tauri tauri-plugin-updater. The updater's 'check' IPC command accepts an allowDowngrades boolean parameter from frontend JavaScript, which can be exploited via XSS to bypass anti-rollback protections and enable downgrade attacks. This affects versions from 2.8.0 up to but not including 2.12.0. The vulnerability has a medium severity with a CVSS score of 6.8.

References

Community reviews

Loading reviews…