Skip to main content
VulnerabilityPublished

CVE-2026-95625: tauri-plugin-updater · Improper Validation of Integrity Check Value

Affects tauri-plugin-updaterSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 2.12.0 when convenient.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.12.0
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade tauri-plugin-updater to 2.12.0.

Affected software

ProductAffectedFixed in
Tauritauri-plugin-updaterAffected
  • >=2.0.0 <2.12.0
  • >=2.12.0
Fixed in
  • 2.12.0
crates.iotauri-plugin-updaterpkg:cargo/tauri-plugin-updaterOther threatsAffected
  • >=2.0.0 <2.12.0
  • >=2.12.0
Fixed in
  • 2.12.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should be cautious about update sources and consider additional validation mechanisms for update manifests if possible.

Description

CVE-2026-95625 is a vulnerability in the Tauri tauri-plugin-updater where the update manifest is not signed or authenticated, allowing an attacker to serve a crafted manifest. This can force the installation of older signed releases despite the anti-rollback check, which only compares an unsigned version field. The vulnerability affects versions >=2.0.0 and later. The CVSS score is 5.9, indicating medium severity.

References

Community reviews

Loading reviews…