Skip to main content
VulnerabilityPublished

CVE-2026-95818: The GNU C Library glibc · Stack-based Buffer Overflow

Affects The GNU C Library glibcSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 3.6 Low : upgrade to 2.45 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
3.6Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.45
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade glibc and the Debian debian/glibc package to 2.45.

Affected software

ProductAffectedFixed in
The GNU C LibraryglibcAffected
  • >=2.14 <2.45
Fixed in
  • 2.45
Debiandebian/glibcpkg:deb/debian/glibcOther threatsAffected
  • >=2.14 <2.45
Fixed in
  • 2.45

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid running untrusted setuid/setgid programs that rely on DT_RPATH or DT_RUNPATH starting with $ORIGIN followed by NUL or '/'.

Description

CVE-2026-95818 is a stack-based buffer overflow vulnerability in the dynamic loader (ld.so) of the GNU C Library (glibc) versions 2.14 through 2.44. This flaw affects setuid/setgid programs that use DT_RPATH or DT_RUNPATH beginning with $ORIGIN followed by a NUL or '/' character. Exploitation can cause the loader to read and write beyond the bounds of internal buffers, leading to crashes or limited disclosure of process memory. The vulnerability has a low CVSS score of 3.6 and requires local attacker privileges with high attack complexity.

References

Community reviews

Loading reviews…