CVE-2026-95861: Ubiquiti Dream Machines · Uncontrolled Recursion
Affects Ubiquiti Dream MachinesSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 5.1.31 soon.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.1.31, 4.0.21, 5.1.26
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 22 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade Dream Machines and Enterprise Firewalls and Dream Routers and Cloud Gateways and Dream Wall and Express 7 to 5.1.31; Express to 4.0.21; UniFi Gateways to 5.1.26.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Ubiquiti IncDream Machines | Affected
| Fixed in
|
| Ubiquiti IncEnterprise Firewalls | Affected
| Fixed in
|
| Ubiquiti IncDream Routers | Affected
| Fixed in
|
| Ubiquiti IncCloud Gateways | Affected
| Fixed in
|
| Ubiquiti IncDream Wall | Affected
| Fixed in
|
| Ubiquiti IncExpress | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restricting network access to trusted users and devices may reduce exposure.
Description
CVE-2026-95861 is an Uncontrolled Recursion vulnerability in Ubiquiti Inc Dream Machines UniFi gateway devices. An attacker with network access could exploit this flaw to cause a Denial of Service (DoS) condition, disrupting device availability. The vulnerability affects multiple versions prior to 5.1.31, 4.0.21, and 5.1.26. The CVSS score is 7.5, indicating high severity. No known exploits are reported in the wild.