CVE-2026-97350: Securepoint SSL VPN Client v2 · Argument Injection
Affects Securepoint SSL VPN Client v2Source CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 2.0.50 when convenient.
Data as of 3 Nov 2026, 15:44 UTC
Thin evidence
One scorer or none| CNA (securepoint) | CVSS 4.0 | 6.9 |
|---|
- Patch
- Available – fixed in 2.0.50
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade Securepoint SSL VPN Client v2 to 2.0.50.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SecurepointSecurepoint SSL VPN Client v2 | Affected
| Fixed in
|
GitHubSecurepoint SSL VPN Client v2pkg:github/Securepoint SSL VPN Client v2Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Securepoint SSL VPN Client version 2.0.50. Users and administrators should upgrade to this version to remediate the vulnerabilities. No additional mitigation steps are indicated by the vendor advisory.
Description
Securepoint SSL VPN Client v2 on Windows has vulnerabilities in how it handles OpenVPN configurations and proxy settings. These flaws allow non-privileged local users to influence operations executed with SYSTEM privileges. Two main issues exist: improper authorization of configuration checksum updates and argument injection via proxy settings. Both enable privilege escalation without requiring administrator rights or direct privileged service communication. The vulnerabilities affect versions from 1.0.2 up to but not including 2.0.50. A fix is available in version 2.0.50.