CVE-2026-119672: MongoDB Database Tools · External Control of File Name or Path
Affects MongoDB Database ToolsSource CVE Database V5
Not known to be exploited · CVSS 5.9 Medium : upgrade to 100.20.1 when convenient.
Data as of 3 Nov 2026, 16:43 UTC
Thin evidence
One scorer or none| CNA (mongodb) | CVSS 4.0 | 5.9 |
|---|---|---|
| CNA (mongodb) | CVSS 3.1 | 4.8 |
- Patch
- Available – fixed in 100.20.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade Database Tools and mongodb/mongo-tools to 100.20.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MongoDBDatabase Tools | Affected
| Fixed in
|
GitHubmongodb/mongo-toolspkg:github/mongodb/mongo-toolsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in MongoDB Database Tools version 100.20.1. Users should upgrade to this version or later to remediate the vulnerability. No additional mitigation actions are indicated by the vendor advisory.
Description
CVE-2026-119672 is a vulnerability in MongoDB Database Tools mongofiles where a filename stored in the database can be externally controlled. An attacker who can modify file metadata can set the filename to '-', causing authorized retrievals without a local destination to write file contents to standard output. If this output is captured and accessible to the attacker, it may disclose GridFS file contents that the attacker cannot directly read. This affects versions from 3.1.4 up to but not including 100.20.1.