Skip to main content
CVE-2026-3608VulnerabilityPublished Updated

SUSE kea · security update for kea

Affects SUSE keaSource GCVE Database

0
Compare
Authoritative record:CVE-2026-3608· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade the Red Hat redhat/kea package to 10.2 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.3% chance of exploitation in 30 days – higher than 72% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Red Hat redhat/kea package to 10.2.

Affected software

ProductAffectedFixed in
Red Hatredhat/keapkg:rpm/redhat/keaOther threatsAffected
  • <10.2
Fixed in
  • 10.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released security updates for affected Kea packages in Red Hat Enterprise Linux 10.0 Extended Update Support. Applying these official patches will remediate the vulnerability. Users should follow the Red Hat advisory instructions at https://access.redhat.com/articles/11258 to update their Kea packages. Since this is not a cloud service, remediation requires applying vendor-provided patches. Patch status is confirmed by the vendor advisory. No alternative mitigations or workarounds are specified.

Description

A reachable assertion vulnerability (CWE-617) in ISC Kea DHCP daemons (kea-ctrl-agent, kea-dhcp-ddns, kea-dhcp4, kea-dhcp6) allows a denial of service via a stack overflow triggered by a maliciously crafted message sent over any configured API socket or HA listener. This affects Kea versions 2.6.0 through 2.6.4 and 3.0.0 through 3.0.2. Red Hat has issued security advisories and updates to address this issue.

References

Community reviews

Loading reviews…