Skip to main content
VulnerabilityPublished

CVE-2026-116589: Datadog dd-trace-py · IAST instrumentation can lead to application DOS

Affects ddtraceSource GCVE Database

0
Authoritative record:CVE-2026-116589· High 8.2

Not known to be exploited · CVSS 8.2 High : upgrade to 4.15.5 soon.

Data as of 27 Oct 2026, 16:28 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.15.5
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade ddtrace to 4.15.5.

Affected software

ProductAffectedFixed in
PyPIddtraceAffected
  • >=3.13.0 <4.15.5
Fixed in
  • 4.15.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in dd-trace-py version 4.15.5; upgrading to this version resolves the issue. If upgrading is not immediately possible, disable IAST by setting DD_IAST_ENABLED=false. Additionally, avoid using '%' string interpolation for user inputs in the monitored application; use str.format or f-strings instead. These mitigations prevent the vulnerability from being triggered.

Description

A vulnerability in dd-trace-py's IAST instrumentation can cause a denial of service by terminating the Python application process when processing certain attacker-controlled inputs. This issue affects only applications with IAST enabled, which is disabled by default. The flaw arises from improper handling of internal errors in string-processing instrumentation. Exploitation requires the vulnerable dd-trace-py version with IAST enabled and exposure of the affected operation to attacker input. A fix is available in version 4.15.5.

References

Community reviews

Loading reviews…