Skip to main content
VulnerabilityPublished

gix-pack has multiple DoS vectors: unchecked indexing panics and uncapped OOM allocations from crafted pack data

Affects gix-packSource GCVE Database

0

CVSS 8.7 High : upgrade to 0.69.0 soon.

Data as of 27 Oct 2026, 01:47 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.69.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

What to do

Upgrade gix-pack to 0.69.0.

Affected software

ProductAffectedFixed in
crates.iogix-packAffected
  • <0.69.0
Fixed in
  • 0.69.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in gix-pack version 0.69.0 that fixes these issues. Users and integrators should upgrade to version 0.69.0 or later. The fix replaces unchecked indexing with safe bounds-checked access and replaces panics with proper error handling. It also introduces configurable maximum object size limits to prevent uncapped memory allocations. Until upgrading, users should avoid cloning or fetching from untrusted or malicious git servers using vulnerable versions.

Description

Multiple denial-of-service vulnerabilities exist in gix-pack versions prior to 0.69.0. Unchecked array indexing in delta data processing can cause panics, leading to process aborts. Additionally, attacker-controlled size headers allow uncapped memory allocations, causing out-of-memory (OOM) kills. These issues are triggered by malicious pack data received during clone or fetch operations. The vulnerabilities affect the gix CLI, any application using the gix crate, and CI/CD systems relying on gitoxide. A fix is available in version 0.69.0.

References

Community reviews

Loading reviews…