VulnerabilityPublished
@vitejs/plugin-rsc has a Denial of Service Vulnerability in React Server Components
Affects @vitejs/plugin-rscSource GCVE Database
0
CVSS 7.5 High : upgrade to 0.5.26 soon.
Data as of 27 Oct 2026, 00:43 UTC
CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
- Patch
- Available – fixed in 0.5.26
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HWhat to do
Upgrade @vitejs/plugin-rsc to 0.5.26.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npm@vitejs/plugin-rsc | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade @vitejs/plugin-rsc to version 0.5.26 or later, which includes the fix for the underlying react-server-dom-webpack vulnerability. This is the official and recommended remediation.
Description
@vitejs/plugin-rsc versions prior to 0.5.26 include a denial of service vulnerability due to an issue in the vendored react-server-dom-webpack package. This vulnerability can cause application availability disruption.
References
Community reviews
Loading reviews…