Skip to main content
CVE-2026-23870VulnerabilityPublished

React server dom parcel: Facebook React has a Denial of Service Vulnerability in React Server Components

Affects react-server-dom-parcelSource GCVE Database

0
Authoritative record:CVE-2026-23870· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 19.0.6 soon.

Data as of 27 Oct 2026, 00:56 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 19.0.6, 19.1.7, 19.2.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade react-server-dom-parcel and react-server-dom-turbopack and react-server-dom-webpack to 19.0.6; react-server-dom-parcel and react-server-dom-turbopack and react-server-dom-webpack to 19.1.7; react-server-dom-parcel and react-server-dom-turbopack and react-server-dom-webpack to 19.2.6.

Affected software

ProductAffectedFixed in
npmreact-server-dom-parcelAffected
  • >=19.0.0 <19.0.6
Fixed in
  • 19.0.6
npmreact-server-dom-turbopackAffected
  • >=19.0.0 <19.0.6
Fixed in
  • 19.0.6
npmreact-server-dom-webpackAffected
  • >=19.0.0 <19.0.6
Fixed in
  • 19.0.6
npmreact-server-dom-parcelAffected
  • >=19.1.0 <19.1.7
Fixed in
  • 19.1.7
npmreact-server-dom-turbopackAffected
  • >=19.1.0 <19.1.7
Fixed in
  • 19.1.7
npmreact-server-dom-webpackAffected
  • >=19.1.0 <19.1.7
Fixed in
  • 19.1.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade react-server-dom-webpack, react-server-dom-parcel, and react-server-dom-turbopack to versions 19.0.6, 19.1.7, or 19.2.6 or later. If your application does not use a server or React Server Components, it is not affected and no action is required.

Description

A denial of service vulnerability exists in React Server Components packages react-server-dom-webpack, react-server-dom-parcel, and react-server-dom-turbopack. The flaw can be triggered by specially crafted HTTP requests to server function endpoints, causing out-of-memory exceptions or excessive CPU usage. Versions 19.0.0 through 19.0.5, 19.1.0 through 19.1.6, and 19.2.0 through 19.2.5 are affected. Fixed versions 19.0.6, 19.1.7, and 19.2.6 have been released. Applications not using a server or React Server Components are not affected.

References

Community reviews

Loading reviews…