Next.js Vulnerable to Denial of Service with Server Components
Affects nextSource GCVE Database
Mentioned vulnerabilities
CVSS 7.5 High : upgrade to 15.5.16 soon.
Data as of 27 Oct 2026, 00:43 UTC
- Patch
- Available – fixed in 15.5.16, 16.2.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HWhat to do
Upgrade next to 15.5.16; next to 16.2.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmnext | Affected
| Fixed in
|
| npmnext | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches by upgrading Next.js to version 15.5.16 or later for the 15.x branch, or 16.2.5 or later for the 16.x branch. These versions contain fixes that prevent the excessive CPU usage during deserialization. No other mitigation is specified or required.
Description
Certain React Server Components packages used by Next.js versions 13.x, 14.x, 15.x prior to 15.5.16, and 16.x prior to 16.2.5 with the App Router are vulnerable to a denial of service (DoS) attack. An attacker can send a specially crafted HTTP request to an App Router Server Function endpoint that triggers excessive CPU usage during deserialization, causing service disruption. This vulnerability is tracked as CVE-2026-23870 and has a high severity rating with a CVSS score of 7.5. Fixed versions 15.5.16 and 16.2.5 are available to mitigate the issue.
References
- github.com/facebook/react/security/advisories/GHSA-rv78-f8rc-xrxh (opens in a new tab)
- github.com/vercel/next.js/security/advisories/GHSA-8h8q-6873-q5fj (opens in a new tab)
- github.com/vitejs/vite-plugin-react/security/advisories/GHSA-w94c-4vhp-22gx (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-23870 (opens in a new tab)
- github.com/vercel/next.js (opens in a new tab)