Skip to main content
VulnerabilityPublished Updated

CVE-2026-22696: dcap-qvl has Missing Verification for QE Identity

Affects dcap-qvlSource GCVE Database

0
Authoritative record:CVE-2026-22696· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical : upgrade to 0.3.9 as a priority.

Data as of 27 Oct 2026, 17:31 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.3.9
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade dcap-qvl and @phala/dcap-qvl to 0.3.9.

Affected software

ProductAffectedFixed in
crates.iodcap-qvlAffected
  • <0.3.9
Fixed in
  • 0.3.9
npm@phala/dcap-qvlAffected
  • <0.3.9
Fixed in
  • 0.3.9
npm@phala/dcap-qvl-webAffected
  • <=0.3.3
Fixed in–
npm@phala/dcap-qvl-nodeAffected
  • <=0.3.3
Fixed in–
PyPIdcap-qvlAffected
  • <0.3.9
Fixed in
  • 0.3.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to dcap-qvl version 0.3.9 or later, which includes the necessary cryptographic verification of the QE Identity signature and enforces policy constraints on the QE Report. Users of the @phala/dcap-qvl-node and @phala/dcap-qvl-web packages should migrate to the pure JavaScript implementation @phala/dcap-qvl. There are no known workarounds; applying the official patch is required to mitigate this vulnerability.

Description

A critical vulnerability in the dcap-qvl library allows attackers to bypass cryptographic verification of the QE Identity signature. This flaw enables forging of QE Identity data to whitelist malicious or non-Intel Quoting Enclaves, undermining the remote attestation security model. The issue affects all deployments using dcap-qvl for SGX or TDX quote verification. The vulnerability is patched in version 0.3.9, which adds the missing verification and enforces policy checks. No workarounds exist; upgrading to the fixed version is required.

References

Community reviews

Loading reviews…