Skip to main content
VulnerabilityPublished

CVE-2026-45572: Decidim · HTML content blocks allow stored script execution

Affects decidim-coreSource GCVE Database

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 0.30.9 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.30.9, 0.31.5, 0.32.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade decidim-core to 0.30.9; decidim-core to 0.31.5; decidim-core to 0.32.0.

Affected software

ProductAffectedFixed in
RubyGemsdecidim-coreAffected
  • <0.30.9
Fixed in
  • 0.30.9
RubyGemsdecidim-coreAffected
  • >=0.31.0.rc1 <0.31.5
Fixed in
  • 0.31.5
RubyGemsdecidim-coreAffected
  • >=0.32.0.rc1 <0.32.0
Fixed in
  • 0.32.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Decidim version 0.30.9. Users should upgrade to this version or later to remediate the vulnerability. As a workaround, restrict admin permissions to trusted users only to prevent untrusted users from injecting malicious scripts. No other mitigations are specifically indicated.

Description

A stored cross-site scripting (XSS) vulnerability exists in Decidim core versions prior to 0.30.9. A privileged admin user who can edit landing pages can inject arbitrary HTML and JavaScript into an HTML content block. This content is rendered without sanitization, allowing script execution in visitors' browsers. Exploitation requires admin-level permissions, reducing practical risk compared to participant-controlled or unauthenticated XSS. A patch is available in Decidim version 0.30.9.

References

Community reviews

Loading reviews…