Skip to main content
VulnerabilityPublished

CVE-2026-45573: Decidim · Push subscriptions can be abused for server-side requests

Affects decidim-coreSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.4 Medium : upgrade to 0.30.9 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.30.9, 0.31.5, 0.32.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade decidim-core to 0.30.9; decidim-core to 0.31.5; decidim-core to 0.32.0.

Affected software

ProductAffectedFixed in
RubyGemsdecidim-coreAffected
  • <0.30.9
Fixed in
  • 0.30.9
RubyGemsdecidim-coreAffected
  • >=0.31.0.rc1 <0.31.5
Fixed in
  • 0.31.5
RubyGemsdecidim-coreAffected
  • >=0.32.0.rc1 <0.32.0
Fixed in
  • 0.32.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Decidim version 0.30.9 and later; upgrading to this version or newer will remediate the vulnerability. As a workaround, disabling the push notifications feature by removing the VAPID keys on the server will prevent exploitation. Users should consult the official Decidim pull request https://github.com/decidim/decidim/pull/16714 for patch details and apply the official fix.

Description

Decidim contains a vulnerability in its push-subscription endpoint where an authenticated user can register an attacker-controlled HTTPS URL. When VAPID delivery is enabled, the server sends outbound POST requests to this stored URL, creating a stored, mostly blind server-side request forgery (SSRF) primitive. This allows interaction with arbitrary HTTPS endpoints reachable from the application server, potentially including internal services. The vulnerability affects Decidim versions prior to 0.30.9.

References

Community reviews

Loading reviews…