Skip to main content
VulnerabilityPublished

CVE-2026-45415: Decidim · CSV census record endpoints improper authorization

Affects decidim-verificationsSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.0 Medium : upgrade to 0.30.9 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.30.9, 0.31.5, 0.32.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade decidim-verifications to 0.30.9; decidim-verifications to 0.31.5; decidim-verifications to 0.32.0.

Affected software

ProductAffectedFixed in
RubyGemsdecidim-verificationsAffected
  • <0.30.9
Fixed in
  • 0.30.9
RubyGemsdecidim-verificationsAffected
  • >=0.31.0.rc1 <0.31.5
Fixed in
  • 0.31.5
RubyGemsdecidim-verificationsAffected
  • >=0.32.0.rc1 <0.32.0
Fixed in
  • 0.32.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Decidim version 0.30.9 and later; upgrading to these versions is recommended. Alternatively, disabling the Organization Census verification method can serve as a temporary workaround. No other specific mitigations are indicated by the vendor advisory.

Description

Decidim's CSV census record admin endpoints lack proper authorization checks, allowing participant managers to access and modify census records. This improper access control enables participant managers, who should only manage participants, to create, update, or delete CSV census rows. The vulnerability affects Decidim versions prior to 0.30.9. The issue was identified as broken access control and has been addressed in patches referenced in Decidim's GitHub repository.

References

Community reviews

Loading reviews…