Skip to main content
CVE-2026-33155VulnerabilityPublished Updated

Deepdiff: From version 5.0.0 to before version 8.6.2, the pickle unpickler _RestrictedUnpickler validates which

Affects deepdiffSource GCVE Database

0
Compare
Authoritative record:CVE-2026-33155· High 8.7

Not known to be exploited · CVSS 8.7 High · fixed in 8.6.2 : patch deepdiff soon.

Data as of 5 Nov 2026, 12:51 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 8.6.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10deepdiffpkg:deb/ubuntu/deepdiff?arch=source&distro=stonkingOther threatsAffected
  • =8.6.1-1
  • =9.0.0-1
Fixed in–
Ubuntu 26.04 LTSdeepdiffpkg:deb/ubuntu/deepdiff?arch=source&distro=resoluteOther threatsAffected
  • =8.1.1-4
  • =8.6.1-1
Fixed in–
Ubuntu 25.10deepdiffpkg:deb/ubuntu/deepdiff?arch=source&distro=questingOther threatsAffected
  • =8.1.1-3
  • =8.1.1-4
Fixed in–
Ubuntu 24.04 LTSdeepdiffpkg:deb/ubuntu/deepdiff?arch=source&distro=nobleOther threatsAffected
  • =6.2.2-1
  • =6.7.1-1
Fixed in–
Ubuntu 22.04 LTSdeepdiffpkg:deb/ubuntu/deepdiff?arch=source&distro=jammyOther threatsAffected
  • 3.3.0-2 – 5.6.0-2
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade DeepDiff to version 8.6.2 or later, where this vulnerability is patched. Avoid loading pickle data from untrusted sources until the update is applied.

Description

DeepDiff versions from 5.0.0 up to but not including 8.6.2 contain a vulnerability in the pickle unpickler _RestrictedUnpickler. This component validates which classes can be loaded but does not restrict constructor arguments, allowing specially crafted pickle payloads to cause excessive memory allocation. A small 40-byte payload can trigger allocation of over 10 GB of memory, leading to application crashes when loading untrusted data. The issue is fixed in version 8.6.2.

References

Community reviews

Loading reviews…