Skip to main content
CVE-2025-58367VulnerabilityPublished Updated

Deepdiff: Versions 5.0.0 through 8.6.0 are vulnerable to class pollution via the Delta class constructor, and when

Affects deepdiffSource GCVE Database

0
Compare
Authoritative record:CVE-2025-58367· Critical 10.0

Not known to be exploited · CVSS 10.0 Critical · fixed in 8.6.1 : patch deepdiff as a priority.

Data as of 5 Nov 2026, 12:51 UTC

CVSS 4.0 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 8.6.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 25.10deepdiffpkg:deb/ubuntu/deepdiff?arch=source&distro=questingOther threatsAffected
  • =8.1.1-3
  • =8.1.1-4
Fixed in–
Ubuntu 24.04 LTSdeepdiffpkg:deb/ubuntu/deepdiff?arch=source&distro=nobleOther threatsAffected
  • =6.2.2-1
  • =6.7.1-1
Fixed in–
Ubuntu 22.04 LTSdeepdiffpkg:deb/ubuntu/deepdiff?arch=source&distro=jammyOther threatsAffected
  • 3.3.0-2 – 5.6.0-2
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade DeepDiff to version 8.6.1 or later, where this vulnerability is fixed. Avoid using vulnerable versions (5.0.0 through 8.6.0). No other mitigations are specified or recommended by the vendor advisory.

Description

DeepDiff versions 5.0.0 through 8.6.0 contain a critical vulnerability involving class pollution via the Delta class constructor. When combined with a gadget in DeltaDiff, this vulnerability enables insecure Pickle deserialization, potentially allowing remote code execution and denial of service. The flaw allows modification of deepdiff.serialization.SAFE_TO_IMPORT to include dangerous classes, such as posix.system, leading to arbitrary code execution if user-controlled input is passed to Delta. This vulnerability is fixed in version 8.6.1.

References

Community reviews

Loading reviews…