CVE-2024-24680: Django Denial-of-service Attack
Affects DjangoSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 3.2.24 soon.
Data as of 4 Nov 2026, 17:49 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 3.2.24, 4.2.10, 5.0.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Feb 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade Django to 3.2.24; Django to 4.2.10; Django to 5.0.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIDjango | Affected
| Fixed in
|
| PyPIDjango | Affected
| Fixed in
|
| PyPIDjango | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Django versions 3.2.24, 4.2.10, and 5.0.2. Users should upgrade to these fixed versions to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
A denial-of-service vulnerability exists in Django's intcomma template filter affecting versions before 3.2.24, 4.2.10, and 5.0.2. The issue occurs when the filter processes very long strings, potentially causing service disruption.
References
- nvd.nist.gov/vuln/detail/CVE-2024-24680 (opens in a new tab)
- github.com/django/django/commit/16a8fe18a3b81250f4fa57e3f93f0599dc4895bc (opens in a new tab)
- github.com/django/django/commit/55519d6cf8998fe4c8f5c8abffc2b10a7c3d14e9 (opens in a new tab)
- github.com/django/django/commit/572ea07e84b38ea8de0551f4b4eda685d91d09d2 (opens in a new tab)
- github.com/django/django/commit/c1171ffbd570db90ca206c30f8e2b9f691243820 (opens in a new tab)
- docs.djangoproject.com/en/5.0/releases/security (opens in a new tab)
- github.com/django/django (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2024-28.yaml (opens in a new tab)
- groups.google.com/forum/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/D2JIRXEDP4ZET5KFMAPPYSK663Q52NEX (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/SN2PLJGYSAAG5KUVIUFJYKD3BLQ4OSN6 (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ZQJOMNRMVPCN5WMIZ7YSX5LQ7IR2NY4D (opens in a new tab)
- djangoproject.com/weblog/2024/feb/06/security-releases (opens in a new tab)