Skip to main content
VulnerabilityPublished Updated

CVE-2024-38875: Django vulnerable to Denial of Service

Affects DjangoSource GCVE Database

0
Compare
Authoritative record:CVE-2024-38875· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 4.2.14 soon.

Data as of 4 Nov 2026, 17:27 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.2.14, 5.0.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade Django to 4.2.14; Django to 5.0.7.

Affected software

ProductAffectedFixed in
PyPIDjangoAffected
  • >=4.2 <4.2.14
Fixed in
  • 4.2.14
PyPIDjangoAffected
  • >=5.0 <5.0.7
Fixed in
  • 5.0.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading Django to version 4.2.14 or later, or 5.0.7 or later. These versions contain fixes that address the denial of service vulnerability in urlize and urlizetrunc. No other mitigation is indicated by the vendor advisory.

Description

Django versions 4.2 prior to 4.2.14 and 5.0 prior to 5.0.7 contain a vulnerability in the urlize and urlizetrunc functions that can be triggered by inputs with a very large number of brackets, leading to a denial of service condition. This issue has been assigned CVE-2024-38875 and is rated as high severity with a CVSS score of 7.5. Fixed versions 4.2.14 and 5.0.7 have been released to address this vulnerability.

References

Community reviews

Loading reviews…