Django versions 4.2 prior to 4.2.14 and 5.0 prior to 5.0.7 contain a vulnerability in the urlize and urlizetrunc functions that can be triggered by inputs with a very large number of brackets, leading to a denial of service condition. This issue has been assigned CVE-2024-38875 and is rated as high severity with a CVSS score of 7.5. Fixed versions 4.2.14 and 5.0.7 have been released to address this vulnerability.