Skip to main content
CVE-2026-118539ExploitPublished

Drupal Commerce Core Vulnerability Exploited Against Online Stores

Source SecurityWeek

0
Compare
Authoritative record:CVE-2026-118539· High

Not known to be exploited : upgrade to 3.3.13 or 2.41 soon.

Data as of 30 Oct 2026, 14:02 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Patch
Available – fixed in 3.3.13, 2.41

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Commerce Core to 3.3.13 or 2.41.

Affected software

ProductAffectedFixed in
DrupalCommerce CoreAffected
  • >=3.0.0 <3.3.13
Fixed in
  • 3.3.13
DrupalCommerce CoreAffected
  • <2.41
Fixed in
  • 2.41

AI-suggested

Drupal has released fixed versions 3.3.13 for the 3.x branch and 8.x-2.41 for the 8.x-2.x branch of the Commerce Core module. Administrators should promptly update to these versions to remediate the vulnerability. Additionally, store owners are advised to audit their orders for inconsistencies that may indicate exploitation. No other mitigations or workarounds are specified.

Description

A highly critical access bypass vulnerability (CVE-2026-118539) in the Drupal Commerce Core module is actively exploited in the wild. This flaw allows unauthenticated attackers to bypass access controls on certain routes and entity fields, potentially leading to financial impact for online store vendors. The vulnerability affects Commerce Core 3.x versions prior to 3.3.13 and earlier 8.x-2.x releases before 8.x-2.41. Drupal urges administrators to update to fixed versions and audit their store orders for inconsistencies. The module is widely used on over 42,000 sites. Drupal assigned a high risk score of 21 out of 25 to this vulnerability. No detailed exploitation methods or attacker identities have been disclosed.

References

Community reviews

Loading reviews…