Skip to main content
CVE-2026-118539VulnerabilityPublished

drupal/commerce · Commerce: This module enables you to sell goods and services to customers through an included shopping cart and

Affects drupal/commerceSource GCVE Database

0

Not known to be exploited : upgrade to 3.3.13 or 2.41.0 soon.

Data as of 28 Oct 2026, 20:42 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Patch
Available – fixed in 3.3.13, 2.41.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade drupal/commerce to 3.3.13 or 2.41.0.

Affected software

ProductAffectedFixed in
Packagist https //packages.drupal.org/8drupal/commerceAffected
  • <2.41.0
  • >=3.0.0 <3.3.13
Fixed in
  • 2.41.0
  • 3.3.13

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading Drupal Commerce to version 2.41.0 or later in the 2.x branch, or to version 3.3.13 or later in the 3.x branch. These versions contain fixes that properly protect the affected routes and entity fields, mitigating the access bypass vulnerability.

Description

A vulnerability in the Drupal Commerce module allows insufficient protection of certain routes and entity fields, leading to an access bypass. This flaw can financially impact the vendor by enabling unauthorized access to commerce functions. The issue affects versions prior to 2.41.0 and versions from 3.0.0 up to but not including 3.3.13. A fix is available in versions 2.41.0 and 3.3.13. The vulnerability is actively exploited in the wild.

References

Community reviews

Loading reviews…