Skip to main content
VulnerabilityPublished

CVE-2026-118540: Commerce · This module enables you to sell goods and services to customers through a shopping cart

Affects drupal/commerceSource GCVE Database

0

Not known to be exploited : upgrade to 3.2.0 or 2.41.0 when convenient.

Data as of 28 Oct 2026, 20:45 UTC

Severity
Medium

Rated Medium by Threat Radar's AI analysis · CVSS not yet scored by NVD

Patch
Available – fixed in 3.2.0, 2.41.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade drupal/commerce to 3.2.0 or 2.41.0.

Affected software

ProductAffectedFixed in
Packagist https //packages.drupal.org/8drupal/commerceAffected
  • <2.41.0
  • >=3.0.0 <3.2.0
Fixed in
  • 2.41.0
  • 3.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading to Drupal Commerce versions 2.41.0 or later in the 2.x branch, or 3.2.0 or later in the 3.x branch to remediate this vulnerability.

Description

A vulnerability in the Drupal Commerce module allows access to unpublished product variations via the JSON:API module without proper permissions. This issue only affects sites that have published products alongside unpublished product variations. Fixed versions 2.41.0 and 3.2.0 address this vulnerability.

References

Community reviews

Loading reviews…