Skip to main content
VulnerabilityPublished

CVE-2026-118541: Commerce · This module enables you to sell goods and services to customers through a shopping cart

Affects drupal/commerceSource GCVE Database

0

Not known to be exploited : upgrade to 3.3.13 or 2.41.0 soon.

Data as of 28 Oct 2026, 20:45 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Patch
Available – fixed in 3.3.13, 2.41.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade drupal/commerce to 3.3.13 or 2.41.0.

Affected software

ProductAffectedFixed in
Packagist https //packages.drupal.org/8drupal/commerceAffected
  • <2.41.0
  • >=3.0.0 <3.3.13
Fixed in
  • 2.41.0
  • 3.3.13

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official fixes by upgrading the Drupal Commerce module to version 2.41.0 or later in the 2.x branch, or to version 3.3.13 or later in the 3.x branch. If upgrading is not immediately possible, ensure that JSON:API or REST write access is disabled to mitigate exploitation risk, as the vulnerability requires these interfaces to be enabled.

Description

A vulnerability in the Drupal Commerce module allows users with permission to manage their own promotions to delete or modify coupons belonging to other promotions due to insufficient access checks on the relationship between promotions and coupons. This issue requires that the site accepts writes via JSON:API or REST, which is not enabled by default, mitigating the risk. Fixed versions 2.41.0 and 3.3.13 address this vulnerability.

References

Community reviews

Loading reviews…