CVE-2026-118544: Commerce · This module enables you to sell goods and services to customers through a shopping cart
Affects drupal/commerceSource GCVE Database
Not known to be exploited : upgrade to 3.3.13 or 2.41.0 when convenient.
Data as of 28 Oct 2026, 20:44 UTC
Rated Medium by Threat Radar's AI analysis · CVSS not yet scored by NVD
- Patch
- Available – fixed in 3.3.13, 2.41.0
Exploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade drupal/commerce to 3.3.13 or 2.41.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Packagist https //packages.drupal.org/8drupal/commerce | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected Drupal Commerce module versions to 2.41.0 or later, or 3.3.13 or later, where the vulnerability is fixed. If upgrading is not immediately possible, disabling the core JSON:API module will mitigate the vulnerability since the issue requires JSON:API to be enabled.
Description
The Drupal Commerce module has a vulnerability where it does not properly restrict product variations returned by entity queries to those viewable by the current user. When the core JSON:API module is enabled, an attacker can make repeated requests to infer certain field values of unpublished product variations or variations of unpublished products. This issue affects versions prior to 2.41.0 and versions from 3.0.0 up to but not including 3.3.13. A fix is available in versions 2.41.0 and 3.3.13.