Skip to main content
Report · Bleeping ComputerAbout CVE-2026-9082Published

Drupal: Critical SQL injection flaw now targeted in attacks

Source Bleeping Computer

0
Compare
Authoritative record:CVE-2026-9082· Critical 9.8

Exploited in the wild · KEV due 27 May 2026 · public exploit available (Exploit-DB) · fixed in 11.3.10 : patch Drupal core now.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
Patch
Available – fixed in 11.3.10, 11.2.12, 11.1.10 +4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 20 May 2026

  2. Exploited in the wild: evidence found.

    Listed in CISA KEV 2 days after disclosure

  3. Observed by OffSeq Mirage: evidence found.

    1 exposed host found; no attack traffic recorded

Timeline

  1. CVE ID reserved

    by Drupal.org

    , 5 hours before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. In Threat Radar

    record ingested

    , 1 hour after disclosure

  4. , 2 days after disclosure

  5. KEV remediation due

    US federal deadline

    , 7 days after disclosure

  6. First Exploit-DB entry (opens in a new tab)

    Drupal Core 10.5.5 - Error-Based SQL Injection

    , 12 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), OffSeq Mirage (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
DrupalDrupal coreAffected
  • >=11.3.0 <11.3.10
Fixed in
  • 11.3.10
DrupalDrupal coreAffected
  • >=11.2.0 <11.2.12
Fixed in
  • 11.2.12
DrupalDrupal coreAffected
  • >=11.0.0 <11.1.10
Fixed in
  • 11.1.10
DrupalDrupal coreAffected
  • >=10.6.0 <10.6.9
Fixed in
  • 10.6.9
DrupalDrupal coreAffected
  • >=10.5.0 <10.5.10
Fixed in
  • 10.5.10
DrupalDrupal coreAffected
  • >=8.9.0 <10.4.10
Fixed in
  • 10.4.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Drupal has released official patches addressing CVE-2026-9082 for all affected supported versions. Website administrators must upgrade immediately to the latest patched versions for their Drupal branch. Even sites not using PostgreSQL should update, as the patches include fixes for other dependencies. Drupal 8 and 9 are end-of-life and receive only best-effort patches; continued use of these versions is risky. No alternative mitigations are indicated beyond applying the official updates promptly.

Description

A critical SQL injection vulnerability (CVE-2026-9082) affecting multiple Drupal versions has been publicly disclosed and is actively targeted by attackers. The flaw impacts Drupal's database abstraction API when using PostgreSQL, allowing unauthenticated attackers to execute arbitrary SQL commands. Exploitation can lead to remote code execution, privilege escalation, and information disclosure. Drupal has released patches for affected versions and strongly urges immediate updates. Drupal 8 and 9 are end-of-life with limited patch support, increasing risk for users on those versions. Exploit attempts have been confirmed in the wild, elevating the urgency of remediation.

References

Community reviews

Loading reviews…