CVE-2025-10929: Drupal Reverse Proxy Header allows Manipulating User-Controlled Variables
Affects drupal/reverse_proxy_headerSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.1.2 when convenient.
Data as of 29 Oct 2026, 22:51 UTC
- Patch
- Available – fixed in 1.1.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade drupal/reverse_proxy_header to 1.1.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Packagistdrupal/reverse_proxy_header | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
Improper Validation of Consistency within Input vulnerability in Drupal Reverse Proxy Header allows Manipulating User-Controlled Variables. This issue affects Reverse Proxy Header: from 0.0.0 before 1.1.2.