CVE-2025-12466: Drupal Simple OAuth (OAuth2) & OpenID Connect allows Authentication Bypass
Affects drupal/simple_oauthSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 6.0.7 soon.
Data as of 29 Oct 2026, 23:13 UTC
- Patch
- Available – fixed in 6.0.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade drupal/simple_oauth to 6.0.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Packagistdrupal/simple_oauth | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected installations of Drupal Simple OAuth (OAuth2) & OpenID Connect to version 6.0.7 or later to remediate this authentication bypass vulnerability. Since a patch is available, applying the official fix is the recommended mitigation.
Description
Drupal Simple OAuth (OAuth2) & OpenID Connect versions from 6.0.0 up to but not including 6.0.7 contain an authentication bypass vulnerability. This flaw allows attackers to bypass authentication mechanisms using an alternate path or channel. The issue is fixed in version 6.0.7.