Dulwich before 1.2.20 contains a commit object parsing vulnerability where the read path in _parse_commit resolves a
Affects dulwichSource GCVE Database
Not known to be exploited · CVSS 8.6 High : upgrade to 1.2.20 soon.
Data as of 5 Nov 2026, 01:29 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.6 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 8.8 |
- Patch
- Available – fixed in 1.2.20
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade dulwich to 1.2.20.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIdulwichpkg:pypi/dulwichOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Dulwich version 1.2.20 and later. Users of Poetry should upgrade Dulwich to version 1.2.20 or later to mitigate this vulnerability. Since Poetry 2.5.1 ships with a vulnerable Dulwich version by default, upgrading Poetry or manually updating Dulwich is recommended.
Description
Dulwich versions before 1.2.20 have a commit object parsing vulnerability where the _parse_commit function incorrectly resolves duplicate tree headers to the last occurrence instead of the first. This behavior diverges from core Git and can be exploited by attackers to craft commit objects that appear benign to Git but resolve differently in Dulwich, potentially leading to execution of malicious build scripts during dependency installation in Poetry 2.5.1, which uses Dulwich by default.
References
- nvd.nist.gov/vuln/detail/CVE-2026-122299 (opens in a new tab)
- github.com/jelmer/dulwich/commit/b77f385b4b0d2d2c7f5ac39dae628948f7ad3a96 (opens in a new tab)
- github.com/jelmer/dulwich/releases/tag/dulwich-1.2.20 (opens in a new tab)
- vulncheck.com/advisories/dulwich-before-commit-parser-tree-header-misinterpretation (opens in a new tab)