Skip to main content
VulnerabilityPublished Updated

craftcms/cms · Duplicate Advisory: Craft CMS: RCE via missing cleanseConfig in FieldsController::actionRenderCardPreview

Affects craftcms/cmsSource GCVE Database

0

CVSS 7.2 High · fixed in 5.9.14 : patch craftcms/cms soon.

Data as of 7 Aug 2026, 06:27 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.9.14
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

What to do

Affected software

ProductAffectedFixed in
Packagistcraftcms/cmsAffected
  • >=5.5.0 <=5.9.13
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Craft CMS to version 5.9.14 or later, where this vulnerability is fixed. No other mitigations are indicated. Patch status is confirmed by the vendor advisory stating the issue is resolved in 5.9.14.

Description

Craft CMS versions 5.5.0 through 5.9.13 contain a remote code execution vulnerability in the FieldsController::actionRenderCardPreview() method. This flaw allows an authenticated admin user to inject Yii2 event handlers via the fieldLayoutConfig POST parameter, leading to arbitrary PHP code execution and potential disclosure of sensitive information such as environment variables and security keys. The vulnerability is fixed in version 5.9.14.

References

Community reviews

Loading reviews…