Skip to main content
CVE-2026-35029VulnerabilityPublished Updated

Red Hat Security Advisory: RHOAI 3.3.4 - Red Hat OpenShift AI

Affects Red HatSource GCVE Database

0
Compare
Authoritative record:CVE-2026-35029· High 8.7

Not known to be exploited · public detection template (Nuclei) · CVSS 8.7 High : upgrade Red Hat litellm to 1.83.0 soon.

Data as of 6 Nov 2026, 02:35 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.83.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Apr 2026

  2. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade litellm and berriai/litellm to 1.83.0.

Affected software

ProductAffectedFixed in
BerriAIlitellmAffected
  • <1.83.0
Fixed in
  • 1.83.0
GitHubberriai/litellmpkg:github/berriai/litellmOther threatsAffected
  • <1.83.0
Fixed in
  • 1.83.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated images for Red Hat OpenShift AI version 3.3.4 containing the fix. Users should upgrade to this version following Red Hat's upgrade documentation. If you cannot patch yet, restrict network access to the LiteLLM service by implementing firewall rules that limit inbound connections to trusted hosts or networks only. This reduces exposure of the vulnerable /config/update endpoint to unauthorized authenticated users. Follow Red Hat's official guidance for upgrading and applying this errata update.

Description

CVE-2026-35029 is a high-severity vulnerability in LiteLLM, an AI Gateway proxy server used in Red Hat OpenShift AI and other Red Hat products. An authenticated user can bypass authorization on the /config/update endpoint to modify proxy configurations and environment variables. This can lead to remote code execution, unauthorized reading of server files, and potential takeover of privileged accounts. Red Hat has released version 3.3.4 of Red Hat OpenShift AI with updated images to address this issue. Mitigation involves restricting network access to the LiteLLM service to trusted hosts only.

References

Community reviews

Loading reviews…