Skip to main content
VulnerabilityPublished Updated

CVE-2026-35029: BerriAI litellm · Incorrect Authorization

Affects BerriAI litellmSource CVE Database V5

0
Compare

Not known to be exploited · public detection template (Nuclei) · 38% EPSS · CVSS 8.7 High : upgrade to 1.83.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
38.6% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.83.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Apr 2026

  2. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade litellm and berriai/litellm to 1.83.0.

Affected software

ProductAffectedFixed in
BerriAIlitellmAffected
  • <1.83.0
Fixed in
  • 1.83.0
GitHubberriai/litellmpkg:github/berriai/litellmOther threatsAffected
  • <1.83.0
Fixed in
  • 1.83.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in LiteLLM version 1.83.0. Users should upgrade to this version to remediate the vulnerability. Until upgrading, restrict network access to the LiteLLM service to trusted hosts or networks only by implementing firewall rules to limit inbound connections to the service port. This reduces exposure of the vulnerable endpoint to unauthorized authenticated users.

Description

CVE-2026-35029 is a high-severity vulnerability in LiteLLM, an AI Gateway proxy server. Prior to version 1.83.0, the /config/update endpoint lacks proper admin role authorization, allowing any authenticated user to modify proxy configurations and environment variables. This can lead to remote code execution, unauthorized reading of server files, and takeover of privileged accounts. The issue is fixed in LiteLLM version 1.83.0.

References

Community reviews

Loading reviews…