CVE-2025-32751: Dell PowerFlex Manager (Appliance) · Insecure Storage of Sensitive Information
Affects Dell PowerFlex Manager (Appliance)Source CVE Database V5
Not known to be exploited · CVSS 5.5 Medium : upgrade to IC 48.383.00 or IC 48.378.00 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in IC 48.383.00, IC 48.378.00, 3.8.3.0 +1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade PowerFlex Manager to IC 48.383.00 or IC 48.378.00 ((Appliance)); 3.8.3.0 or 3.7.8.0 ((Rack)).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DellPowerFlex Manager (Appliance) | Affected
| Fixed in
|
| DellPowerFlex Manager (Rack) | Affected
| Fixed in
|
| DellPowerFlex Manager (Rack) | Affected
| Fixed in
|
| DellPowerFlex Manager | Affected
| Fixed in– |
AI-suggested
If you cannot patch yet, restrict local access to trusted users only and monitor for unauthorized access attempts. Avoid deploying affected versions in untrusted environments. Follow Dell's security advisories for updates on remediation.
Description
Dell PowerFlex Manager, version(s) <=4.6.2, contain(s) an Insecure Storage of Sensitive Information vulnerability. A low privileged attacker with local access could potentially exploit this vulnerability, leading to unauthorized access to sensitive information.
References
- dell.com/support/kbdoc/en-us/000391568/dsa-2025-435-security-update-for-dell-powerflex-rack-multiple-third-party-component-vulnerabilities (opens in a new tab)
- dell.com/support/kbdoc/en-us/000391392/dsa-2025-434-security-update-for-dell-powerflex-appliance-multiple-third-party-component-vulnerabilities (opens in a new tab)