Skip to main content
VulnerabilityPublished Updated

getgrav/grav · Duplicate Advisory: Grav: XSS Blueprint Validation Bypass via Twig String Concatenation

Affects getgrav/gravSource GCVE Database

0

CVSS 6.1 Medium · fixed in 2.0.1 : update getgrav/grav when convenient.

Data as of 17 Sep 2026, 02:03 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.0.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

What to do

Affected software

ProductAffectedFixed in
Packagistgetgrav/gravAffected
  • =2.0.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official fix is available in Grav version 2.0.1. Users should upgrade from version 2.0.0 to 2.0.1 or later to remediate this vulnerability. No other mitigations are indicated by the vendor advisory.

Description

Grav version 2.0.0 contains a cross-site scripting (XSS) vulnerability related to its blueprint validation process. The vulnerability arises when Twig content processing is enabled, allowing an attacker with page-write API permissions to bypass the XSS validator by using Twig string concatenation to construct malicious event handlers or tags dynamically. This results in arbitrary JavaScript execution in visitors' browsers. The issue was fixed in version 2.0.1.

References

Community reviews

Loading reviews…