Skip to main content
VulnerabilityPublished Updated

getgrav/grav · Duplicate Advisory: Grav: detectXss() misses an event-handler attribute after an unpaired quote in an unquoted attribute value, giving stored XSS

Affects getgrav/gravSource GCVE Database

0

CVSS 8.7 High · fixed in 2.0.15 : patch getgrav/grav soon.

Data as of 18 Sep 2026, 01:26 UTC

CVSS 3.1 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.0.15
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

What to do

Affected software

ProductAffectedFixed in
Packagistgetgrav/gravAffected–Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Grav version 2.0.15. Users should upgrade to version 2.0.15 or later to remediate this vulnerability. No additional mitigation steps are indicated in the advisory.

Description

Grav before version 2.0.15 has a stored cross-site scripting (XSS) vulnerability in the detectXss() function. The flaw allows authenticated editors to inject event-handler attributes such as onerror= by exploiting unpaired quotes in unquoted attribute values, bypassing event-handler detection. This can lead to execution of malicious scripts in visitors' browsers when the affected page content is rendered.

References

Community reviews

Loading reviews…