Skip to main content
VulnerabilityPublished Updated

Yewtube: yt-dlp: Arbitrary command injection possible if --exec option used with yt-dlp

Affects yewtubeSource GCVE Database

0

CVSS 7.5 High : upgrade to 2.13.1_3 soon.

Data as of 18 Sep 2026, 01:56 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.13.1_3
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

What to do

Upgrade yewtube to 2.13.1_3.

Affected software

ProductAffectedFixed in
Homebrewyewtubepkg:brew/yewtubeOther threatsAffected
  • >=2.10.5 <2.13.1_3
Fixed in
  • 2.13.1_3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in yt-dlp version 2026.06.09 which restricts --exec conversions to safe ones and limits characters in command templates. Users should upgrade to 2026.06.09 or later. Alternatively, users can mitigate by only using safe conversions (%()d, %()i, %()f, %()q) in --exec templates, avoid using output template syntax in --exec, or avoid using the --exec option entirely.

Description

yt-dlp's --exec option is vulnerable to arbitrary command injection when unsafe string formatting conversions are used in the command template. This allows an attacker to execute arbitrary shell commands via maliciously crafted video metadata. The vulnerability affects users who use unsafe conversions like %()s in --exec templates. yt-dlp 2026.06.09 fixes this by restricting allowed conversions to safe ones and limiting characters in templates. Users can mitigate by upgrading or avoiding unsafe conversions or the --exec option altogether.

References

Community reviews

Loading reviews…