Skip to main content
VulnerabilityPublished Updated

CVE-2026-46374: Uncontrolled Resource Consumption in SQLFluff Parser

Affects sqlfluffSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 4.2.0 soon.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade sqlfluff to 4.2.0.

Affected software

ProductAffectedFixed in
Homebrewsqlfluffpkg:brew/sqlfluffOther threatsAffected
  • >=0.8.2 <4.2.0
Fixed in
  • 4.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade SQLFluff to version 4.2.0 or later, which includes a default-enabled configurable parse node limit to prevent resource exhaustion. No additional action is required if running 4.2.0 or newer.

Description

CVE-2026-46374 is a vulnerability in SQLFluff parser versions from 0.8.2 up to but not including 4.2.0 that allows an untrusted user to cause a Denial of Service (DoS) by submitting a maliciously long SQL query. This triggers uncontrolled resource consumption during parsing. The issue is addressed in version 4.2.0 and later, which introduces a configurable parse node limit enabled by default to prevent such exploits.

References

Community reviews

Loading reviews…