CVE-2026-46373: SQLFluff · Recursive Stack Overflow in Parser
Affects sqlfluffSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 4.1.0 soon.
Data as of 1 Nov 2026, 20:01 UTC
- Patch
- Available – fixed in 4.1.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade sqlfluff to 4.1.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewsqlfluffpkg:brew/sqlfluffOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade SQLFluff to version 4.1.0 or later, which includes a default-enabled configurable recursion limit to prevent recursive stack overflow. No additional mitigation is required if this version is deployed.
Description
SQLFluff versions prior to 4.1.0 have a vulnerability where an attacker can cause a denial of service by submitting SQL queries with excessive nesting, leading to recursive stack overflow in the parser. This affects deployments that lint SQL queries from untrusted users. The issue is fixed in version 4.1.0 by introducing a configurable recursion limit enabled by default.