Skip to main content
VulnerabilityPublished Updated

CVE-2025-43859: Yewtube · h11 accepts some malformed Chunked-Encoding bodies

Affects yewtubeSource GCVE Database

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 2.12.1_1 as a priority.

Data as of 30 Oct 2026, 05:16 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.12.1_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade yewtube to 2.12.1_1.

Affected software

ProductAffectedFixed in
Homebrewyewtubepkg:brew/yewtubeOther threatsAffected
  • >=2.10.5 <2.12.1_1
Fixed in
  • 2.12.1_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in h11 version 0.15.0 that corrects the parsing of chunked bodies. Since exploitation requires both h11 and a buggy proxy, fixing either component fully mitigates the issue. Users should upgrade h11 to 0.15.0 or later. No additional mitigations are required if the patch is applied.

Description

A vulnerability in h11's handling of HTTP/1.1 chunked transfer encoding allows malformed chunked bodies to be accepted due to lenient parsing of trailing line terminators. This can lead to HTTP request smuggling when combined with a proxy that parses chunked bodies differently. The issue is fixed in h11 version 0.15.0. Exploitation requires both h11 and a buggy proxy component, so fixing either mitigates the risk.

References

Community reviews

Loading reviews…