CVE-2026-26331: yt-dlp · Arbitrary Command Injection when using the `--netrc-cmd` option
Affects moodle-dlSource GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 2.3.13_6 soon.
Data as of 1 Nov 2026, 11:02 UTC
- EPSS
- 1.8% chance of exploitation in 30 days – higher than 78% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.3.13_6
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade moodle-dl to 2.3.13_6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmoodle-dlpkg:brew/moodle-dlOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in yt-dlp version 2026.02.21 that validates netrc "machine" values to prevent command injection. Users should upgrade to this version or later. Users who do not use the --netrc-cmd option or netrc_cmd Python API parameter are not affected and do not need to take action.
Description
A command injection vulnerability (CVE-2026-26331) exists in yt-dlp when using the --netrc-cmd option or netrc_cmd Python API parameter. This flaw allows attackers to execute arbitrary shell commands by supplying a malicious URL that influences the netrc "machine" value passed unsafely to a shell command. The vulnerability affects yt-dlp versions prior to 2026.02.21. The issue is mitigated in version 2026.02.21 by validating netrc "machine" values. Users not using the --netrc-cmd option or netrc_cmd parameter are not affected. No active exploitation has been observed in the wild.
References
- github.com/yt-dlp/yt-dlp/security/advisories/GHSA-g3gw-q23r-pgqm (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-26331 (opens in a new tab)
- github.com/yt-dlp/yt-dlp/commit/1fbbe29b99dc61375bf6d786f824d9fcf6ea9c1a (opens in a new tab)
- github.com/yt-dlp/yt-dlp (opens in a new tab)
- github.com/yt-dlp/yt-dlp/releases/tag/2026.02.21 (opens in a new tab)