Skip to main content
VulnerabilityPublished Updated

Moodle dl: yt-dlp: Arbitrary command injection possible if --exec option used with yt-dlp

Affects moodle-dlSource GCVE Database

0

CVSS 7.5 High : upgrade to 2.3.13_11 soon.

Data as of 4 Oct 2026, 21:39 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.3.13_11
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

What to do

Upgrade moodle-dl to 2.3.13_11.

Affected software

ProductAffectedFixed in
Homebrewmoodle-dlpkg:brew/moodle-dlOther threatsAffected
  • >=2.3.13 <2.3.13_11
Fixed in
  • 2.3.13_11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in yt-dlp version 2026.06.09. Users should upgrade to this version or later to mitigate the vulnerability. The patch restricts allowed string formatting conversions and limits characters in command templates to safe values. Users should avoid using unsafe conversions like %()s in their --exec templates until patched.

Description

A command injection vulnerability exists in yt-dlp's --exec option when unsafe string formatting conversions are used in the command template. This allows attackers to inject arbitrary shell commands via crafted video metadata. The issue affects users who use unsafe conversions like %()s in their --exec templates. A fix is available in yt-dlp version 2026.06.09 that restricts allowed conversions and limits characters in command templates.

References

Community reviews

Loading reviews…