Skip to main content
VulnerabilityPublished Updated

Duplicate Advisory: Nuxt dev server vite-node IPC socket is world-connectable on Linux

Affects nuxtSource GCVE Database

0

CVSS 5.5 Medium : upgrade to 4.4.7 when convenient.

Data as of 24 Sep 2026, 07:01 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.4.7
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

What to do

Upgrade nuxt to 4.4.7.

Affected software

ProductAffectedFixed in
npmnuxtAffected
  • >=4.0.0 <4.4.7
Fixed in
  • 4.4.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade Nuxt to version 4.4.7 or later (for Nuxt 4) or 3.21.7 or later (for Nuxt 3) to remediate this issue. Since this affects only the development server on Linux, avoiding running the development server on multi-user systems or restricting local user access can reduce risk until patched.

Description

Nuxt versions 4.0.0 before 4.4.7 and 3.18.0 before 3.21.7 have a vulnerability in the development server on Linux where the vite-node IPC server binds to an abstract-namespace Unix socket without permission restrictions. This allows local unprivileged users to connect to the socket and potentially read sensitive files such as .env and SSH keys through the SSR plugin pipeline. Production builds are not affected as this IPC server runs only in development mode.

References

Community reviews

Loading reviews…